$1.99
View on iTunes
Category: Photography
Oct 27, 2011
Version: 2.6.1
15.0 MB
Seller: MotionOne.co.Ltd

© MotionOne.co.Ltd

LANGUAGES: English, Chinese, French, German, Japanese, Korean, Spanish, Thai

REQUIREMENTS: Compatible with iPhone, iPod touch, and iPad. Requires iOS 3.0 or later
PhotoShake!
Screenshots
VERSION 2.6.1
VERSION 2.6.0
VERSION 2.5.8
VERSION 2.5.5
VERSION 2.5.0
VERSION 2.2.5
VERSION 2.1.5
VERSION 2.1.0
VERSION 2.0.1
VERSION 1.4.0
VERSION 1.3.1
VERSION 1.3.0
VERSION 1.2.0
VERSION 1.0.9
VERSION 1.0.5